Category Virtualization Training

Step-by-Step Proxmox and Ceph High Availability Setup Guide | Free High Availability Storage

Prerequisites
Three or more nodes: Ensure you have at least three nodes to create a Ceph cluster.
Proxmox VE installed on all nodes: Ensure all nodes have Proxmox VE installed and network connectivity between them.
Network Configuration: Proper network setup for cluster communication and Ceph replication.

Step 1: Prepare Proxmox Nodes

  1. Update and Upgrade Proxmox VE on all nodes:

apt update && apt full-upgrade -y

2. Ensure that all nodes have the same version of Proxmox VE:

pveversion

Step 2: Set Up the Proxmox Cluster

  1. Create a new cluster on the first node:
    • pvecm create my-cluster
  2. Add the other nodes to the cluster:
    • pvecm add <IP_of_first_node>
  3. Verify the cluster status:
    • pvecm status

Step 3: Install Ceph on Proxmox Nodes

  1. Install Ceph packages on all nodes:

install ceph ceph-mgr -y

Step 4: Create the Ceph Cluster

  1. Initialize the Ceph cluster on the first node:
    • pveceph init --network <cluster_network>
  2. Create the manager daemon on the first node:
    • pveceph createmgr

Step 5: Add OSDs (Object Storage Daemons)

  1. Prepare disks on each node for Ceph OSDs:
    • pveceph createosd /dev/sdX
  2. Repeat the process for each node and disk.

Step 6: Create Ceph Pools

  1. Create a Ceph pool for VM storage:
    • pveceph pool create mypool 128

Step 7: Configure Proxmox to Use Ceph Storage

  1. Add the Ceph storage to Proxmox:
    • Navigate to Datacenter > Storage > Add > RBD.
    • Enter the required details like ID, Pool, and Monitor hosts.
    • Save the configuration.

Step 8: Enable HA (High Availability)

  1. Configure HA on Proxmox:
    • Navigate to Datacenter > HA.
    • Add resources (VMs or containers) to the HA manager.
    • Configure the HA policy and set desired node priorities.

Step 9: Testing High Availability

  1. Simulate node failure: Power off one of the nodes and observe how the VMs or containers are automatically migrated to other nodes.

Step 10: Monitoring and Maintenance

  1. Use the Proxmox and Ceph dashboards to monitor the health of your cluster.
  2. Regularly update all nodes to ensure stability and security.

Optional: Additional Ceph Configuration

  1. Add Ceph Monitors for redundancy:bashKodu kopyalapveceph createmon
  2. Add more Ceph MDS (Metadata Servers) if using CephFS:bashKodu kopyalapveceph createmds
  3. Tune Ceph settings for performance and reliability based on your specific needs.

By following these steps, you will have a robust Proxmox VE and Ceph high availability setup, ensuring that your VMs and containers remain highly available even in the event of hardware failures.

Free FortiGate Install and Configuration | Create Fortigate LAB for Training

1. Downloading Free FortiGate VM

Fortinet offers a free version of FortiGate VM for various hypervisors including VMware, Hyper-V, KVM, and more. Follow these steps to download it:

  1. Visit the Fortinet Support Portal:
    • Go to Fortinet Support.
    • Log in or create a new account if you don’t have one.
  2. Download the FortiGate VM:
    • Navigate to the “Download” section.
    • Select “VM Images” and choose the appropriate hypervisor (e.g., VMware ESXi, Microsoft Hyper-V, etc.).
    • Download the FortiGate VM package.

2. Deploying FortiGate VM on Your Hypervisor

The deployment process may vary slightly depending on your hypervisor. Below are steps for VMware ESXi:

  1. Deploy OVF Template:
    • Open your VMware vSphere Client.
    • Right-click on your desired host or cluster and select “Deploy OVF Template.”
    • Follow the wizard, selecting the downloaded FortiGate VM OVF file.
    • Configure the VM settings (name, datastore, network mapping, etc.).
    • Finish the deployment process.
  2. Power On the VM:
    • Once the deployment is complete, power on the FortiGate VM.

3. Initial Configuration

  1. Access the FortiGate Console:
    • Use the vSphere Client to open the console of the FortiGate VM.
    • The initial login credentials are usually admin for the username and a blank password.
  2. Set the Password:
    • You will be prompted to set a new password for the admin user.
  3. Configure the Management Interface:
    • Assign an IP address to the management interface.
    • Example commands:

config system interface
edit port1
set ip 192.168.1.99/24
set allowaccess http https ping ssh
next
end

  1. Access the Web Interface:
    • Open a web browser and navigate to https://<management-ip>.
    • Log in with the admin credentials.

4. Basic Setup via Web Interface

  1. System Settings:
    • Navigate to System > Settings.
    • Set the hostname, time zone, and DNS servers.
  2. Network Configuration:
    • Configure additional interfaces if needed under Network > Interfaces.
    • Create VLANs, set up DHCP, etc.
  3. Security Policies:
    • Define security policies to control traffic flow under Policy & Objects > IPv4 Policy.
    • Set source and destination interfaces, addresses, and services.
  4. Enable Features:
    • Enable and configure additional features like IPS, Antivirus, Web Filtering, etc., under Security Profiles.

5. Connecting to the Internet

  1. WAN Interface Configuration:
    • Configure the WAN interface with the appropriate settings (static IP, DHCP, PPPoE, etc.).
  2. Routing:
    • Set up a default route under Network > Static Routes pointing to the WAN gateway.
  3. NAT Configuration:
    • Configure NAT settings under Policy & Objects > NAT.

6. Licensing

  • The free version of FortiGate VM comes with limited features. For full functionality, you may need to purchase a license and activate it under System > FortiGuard.

Free Open Source Router and Firewall | How to Install VyOS and Configure OSPF: Step-by-Step Guide

VyOS Installation and Configuration Guide

Introduction

VyOS is an open-source network operating system based on Debian GNU/Linux that provides software-based network routing, firewall, and VPN functionality. This guide covers the installation and configuration of VyOS, including setting up OSPF.

Installation of VyOS

1. Download VyOS ISO:

   – Go to the VyOS download page and download the ISO image of the latest stable version.

2. Create a Bootable USB Drive:

   – For Windows: Use Rufus to create a bootable USB drive.

   – For Linux/macOS: Use the `dd` command.

3. Boot from the USB Drive:

   – Insert the USB drive into your server or PC and boot from it. You may need to change the boot order in the BIOS/UEFI settings.

4. Install VyOS:

   – Once booted, you will be presented with the VyOS live environment. Log in with the default credentials:

     Username: vyos
     Password: vyos

   – To start the installation, enter:

     install image

   – Follow the prompts to select the installation disk, partitioning scheme, and other options. You will also set a password for the `vyos` user and create a GRUB bootloader.

5. Reboot:

   – After the installation completes, reboot the system and remove the USB drive. The system will boot into the installed VyOS.

Basic Configuration of VyOS

1. Log In:

   – Log in with the user `vyos` and the password you set during installation.

2. Enter Configuration Mode:

   configure

3. Set Hostname:

   set system host-name my-router
   commit
   save

4. Configure Network Interfaces:

   – Identify the network interfaces using the `show interfaces` command.

   – Configure an interface (e.g., `eth0`) with a static IP address:

     set interfaces ethernet eth0 address ‘192.168.1.1/24’
     commit
     save

5. Configure Default Gateway:

   set protocols static route 0.0.0.0/0 next-hop 192.168.1.254
   commit
   save

6. Set DNS Servers:

   set system name-server 8.8.8.8
   set system name-server 8.8.4.4
   commit
   save

7. Enable SSH:

   set service ssh port 22
   commit
   save

Configuring OSPF

Enable OSPF

To configure OSPF (Open Shortest Path First) on VyOS:

1. Enter Configuration Mode:

   configure

2. Enable OSPF:

   set protocols ospf parameters router-id 1.1.1.1

   Replace `1.1.1.1` with a unique router ID for the OSPF instance.

Configure OSPF on Interfaces

Specify which interfaces will participate in OSPF and their respective areas:

   set protocols ospf area 0 network 192.168.1.0/24
   set protocols ospf area 0 network 192.168.2.0/24

   Replace `192.168.1.0/24` and `192.168.2.0/24` with the actual network addresses of your interfaces.

Adjust OSPF Interface Parameters (Optional)

You can adjust OSPF interface parameters like cost, hello interval, and dead interval:

   set interfaces ethernet eth0 ip ospf cost 10
   set interfaces ethernet eth0 ip ospf hello-interval 10
   set interfaces ethernet eth0 ip ospf dead-interval 40

   Replace `eth0` with your actual interface name.

Commit and Save the Configuration

   commit
   save

Example Configuration for OSPF

Here is an example configuration where two interfaces (`eth0` and `eth1`) participate in OSPF with different network segments.

Configuration for Router 1:

configure
set interfaces ethernet eth0 address ‘192.168.1.1/24’
set interfaces ethernet eth1 address ‘10.1.1.1/24’

set protocols ospf parameters router-id 1.1.1.1
set protocols ospf area 0 network 192.168.1.0/24
set protocols ospf area 0 network 10.1.1.0/24

commit
save

Configuration for Router 2:

configure
set interfaces ethernet eth0 address ‘192.168.1.2/24’
set interfaces ethernet eth1 address ‘10.1.2.1/24’

set protocols ospf parameters router-id 2.2.2.2
set protocols ospf area 0 network 192.168.1.0/24
set protocols ospf area 0 network 10.1.2.0/24

commit
save

Verifying OSPF Configuration

1. Check OSPF Neighbors:

   show ip ospf neighbor

2. Check OSPF Routes:

   show ip route ospf

3. Check OSPF Interface Status:

   show ip ospf interface

Additional OSPF Configurations

Configuring OSPF Authentication

To enhance security, you can configure OSPF authentication on the interfaces:

1. Set Authentication Type and Key:

   set interfaces ethernet eth0 ip ospf authentication message-digest
   set interfaces ethernet eth0 ip ospf message-digest-key 1 md5 ‘yourpassword’

   Replace `yourpassword` with a secure password.

2. Configure OSPF Area Authentication:

   set protocols ospf area 0 authentication message-digest

Configuring OSPF Redistribution

To redistribute routes from other protocols (e.g., BGP) into OSPF:

1. Set Redistribution:

   set protocols ospf redistribute bgp
   commit
   save

Troubleshooting OSPF

1. Check OSPF Process:

   show ip ospf

2. Check OSPF Logs:

   show log

3. Debug OSPF:

   monitor protocol ospf

Proxmox VM Live Migration | Migrate VM to another host without Downtime

  1. Cluster Setup: Ensure that your Proxmox hosts are part of the same cluster. A Proxmox cluster consists of multiple Proxmox VE servers (nodes) combined to offer high availability and load balancing to virtual machines. Nodes in a cluster share resources such as storage and can migrate VMs between each other.
  2. Shared Storage: Live migration requires shared storage accessible by both the source and target hosts. This shared storage can be implemented using technologies like NFS, iSCSI, or Ceph. Shared storage allows the VM’s disk images and configuration files to be accessed by any node in the cluster.
  3. Migration Prerequisites: Before initiating a live migration, ensure that the target host has enough resources (CPU, memory, storage) to accommodate the migrating VM. Proxmox will check these prerequisites before allowing the migration to proceed.
  4. Initiating Migration: In the Proxmox web interface (or using the Proxmox command-line interface), select the VM you want to migrate and choose the “Migrate” option. Proxmox will guide you through the migration process.
  5. Migration Process:
    • Pre-Copy Phase: Proxmox starts by copying the memory pages of the VM from the source host to the target host. This is done iteratively, with the majority of memory pages copied in the initial phase.
    • Stopping Point: At a certain point during the migration, Proxmox determines a stopping point. This is the point at which the VM will be paused briefly to perform a final synchronization of memory pages and state information.
    • Pause and Synchronization: The VM is paused on the source host, and any remaining memory pages and state information are transferred to the target host. This pause is usually very brief, minimizing downtime.
    • Completion: Once the final synchronization is complete, the VM is resumed on the target host. From the perspective of the VM and its users, the migration is seamless, and the VM continues to run without interruption on the target host.
  6. Post-Migration: After the migration is complete, the VM is running on the target host. You can verify this in the Proxmox web interface or using the command-line tools. The source host frees up resources previously used by the migrated VM.
  7. High Availability (HA): In a Proxmox cluster with HA enabled, if a host fails, VMs running on that host can be automatically migrated to other hosts in the cluster, ensuring minimal downtime.

Overall, Proxmox VM live migration is a powerful feature that enables you to move virtual machines between hosts in a Proxmox cluster with minimal downtime, providing flexibility and high availability for your virtualized environment.

Proxmox Cluster | Free Virtualization with HA Feature | Step by Step

    1. Cluster Configuration:
      • Nodes: A Proxmox cluster consists of multiple nodes, which are physical servers running Proxmox VE.
      • Networking: Nodes in a Proxmox cluster should be connected to a common network. A private network for internal communication and a public network for client access are typically configured.
      • Shared Storage: Shared storage is crucial for a Proxmox cluster to enable features like live migration and high availability. This can be achieved through technologies like NFS, iSCSI, or Ceph.
    2. High Availability (HA):
      • Proxmox VE includes a feature called HA, which ensures that critical VMs are automatically restarted on another node in the event of a node failure.
      • HA relies on fencing mechanisms to isolate a failed node from the cluster and prevent split-brain scenarios. This can be achieved through power fencing (e.g., IPMI, iLO, iDRAC) or network fencing (e.g., switch port blocking).
      • When a node fails, the HA manager on the remaining nodes detects the failure and initiates the restart of the affected VMs on healthy nodes.
    3. Corosync and Pacemaker:
      • Proxmox VE uses Corosync as the messaging layer and Pacemaker as the cluster resource manager. These components ensure that cluster nodes can communicate effectively and coordinate resource management.
      • Corosync provides a reliable communication channel between nodes, while Pacemaker manages the resources (VMs, containers, services) in the cluster and ensures they are highly available.
    4. Resource Management:
      • Proxmox clusters allow for dynamic resource allocation, allowing VMs and containers to use resources based on demand.
      • Memory and CPU resources can be allocated and adjusted for each VM or container, and live migration allows these resources to be moved between nodes without downtime.
    5. Backup and Restore:
      • Proxmox includes backup and restore functionality, allowing administrators to create scheduled backups of VMs and containers.
      • Backups can be stored locally or on remote storage, providing flexibility in backup storage options.
    6. Monitoring and Logging:
      • Proxmox provides monitoring and logging capabilities to help administrators track the performance and health of the cluster.
      • The web interface includes dashboards and graphs for monitoring resource usage, as well as logs for tracking cluster events.
    7. Updates and Maintenance:
      • Proxmox clusters can be updated and maintained using the web interface or command-line tools. Updates can be applied to individual nodes or the entire cluster.

    Replace expensive VMware to Proxmox, Free Virtualization Platform | How to Install Proxmox

    1. Download Proxmox VE ISO:
    2. Create a Bootable USB Drive:
    3. Boot from USB Drive:
      • Insert the bootable USB drive into the server where you want to install Proxmox VE.
      • Power on or restart the server and boot from the USB drive. You may need to change the boot order in the BIOS settings to boot from USB.
    4. Proxmox VE Installer:
      • Once the server boots from the USB drive, you’ll see the Proxmox VE installer menu.
      • Select “Install Proxmox VE” and press Enter.
    5. Select Installation Target:
      • Select the target disk where you want to install Proxmox VE. This will typically be the server’s local disk.
      • You can choose to use the entire disk for Proxmox VE or manually partition the disk.
    6. Set Root Password:
      • Set a password for the root user of the Proxmox VE system.
    7. Configure Network:
      • Configure the network settings for Proxmox VE. This includes setting the IP address, netmask, gateway, and DNS servers.
    8. Begin Installation:
      • Review the installation summary and confirm to begin the installation process.
    9. Installation Progress:
      • The installer will copy the necessary files and install Proxmox VE on the selected disk. This may take some time depending on your hardware.
    10. Installation Complete:
      • Once the installation is complete, remove the USB drive and reboot the server.
    11. Access Proxmox VE Web Interface:
      • Open a web browser on a computer connected to the same network as the Proxmox VE server.
      • Enter the IP address of the Proxmox VE server in the address bar.
      • Log in to the Proxmox VE web interface using the root user and the password you set during installation.
    12. Configure Proxmox VE:
      • From the web interface, you can configure additional settings such as storage, networks, and backups.
    13. Create VMs and Containers:
      • Use the web interface to create virtual machines (VMs) and containers to run your applications and services.

    Login to ESXi with Domain User | VMware ESXi Active Directory Authentication

    Configuring VMware ESXi for Active Directory (AD) authentication involves joining the ESXi host to the Active Directory domain and configuring user permissions accordingly. Here are the steps:

    1. Access the ESXi Host:

    • Connect to the ESXi host using the vSphere Client or vSphere Web Client.

    2. Configure DNS Settings:

    • Ensure that the DNS settings on the ESXi host are correctly configured, and it can resolve the Active Directory domain controller’s name. You can set the DNS configuration in the ESXi host under “Networking” > “TCP/IP Configuration.”

    3. Join ESXi Host to Active Directory:

    • In the vSphere Client, navigate to the “Host” in the inventory and select the “Configure” tab.
    • Under the “System” section, select “Authentication Services.”
    • Click “Join Domain” or “Properties” depending on your ESXi version.
    • Enter the domain information, including the domain name, username, and password with the necessary permissions to join the domain.
    • Click “Join Domain” or “OK.”

    Example:

    • Domain: example.com
    • Username: domain_admin
    • Password: ********

    4. Verify Domain Join:

    • After joining the domain, you should see a success message. If not, check the credentials and network connectivity.

    5. Configure Permission:

    • Go to the “Permissions” tab in the “Host” section.
    • Add the AD user account to the appropriate role (e.g., Administrator or a custom role).

    Example (PowerCLI):

    New-VIPermission -Principal "EXAMPLE\domain_user" -Role "Admin" -Entity $esxiHost

    6. Test AD Authentication:

    • Log out of the vSphere Client and log in using an Active Directory account. Use the format “DOMAIN\username” or “username@domain.com” depending on your environment.

    Example:

    • Server: esxi.example.com
    • Username: example\domain_user
    • Password: ********

    7. Troubleshooting:

    • If authentication fails, check the ESXi logs for any error messages related to authentication or domain joining.
    • Ensure that time synchronization is correct between the ESXi host and the domain controller.
    • Verify that the Active Directory user account has the necessary permissions.

    Note: Always refer to the official VMware documentation for your specific ESXi version for the most accurate and up-to-date information. The steps might slightly differ based on the ESXi version you are using.

    vCenter Installation and Configuration

    Prerequisites:

    1. Hardware Requirements:
      • Verify that your hardware meets the requirements for vCenter installation.
      • Ensure that the hardware is on the VMware Compatibility Guide.
    2. Software Requirements:
      • Download the vCenter Server installer from the VMware website.
    3. Database:
      • Decide whether to use the embedded PostgreSQL database or an external database like Microsoft SQL Server or Oracle.

    Installation Steps:

    1. Run the Installer:
      • Mount the vCenter Server ISO or run the installer directly.
      • Select “vCenter Server” from the installer menu.
    2. Introduction:
      • Click “Next” on the introduction screen.
    3. Accept the License Agreement:
      • Read and accept the license agreement.
    4. Select Deployment Type:
      • Choose between a vCenter Server with an embedded Platform Services Controller (PSC) or an external PSC.
    5. System Configuration:
      • Enter the system name and set the Single Sign-On (SSO) password.
      • Configure the network settings.
    6. Select Database:
      • Choose between the embedded PostgreSQL database or an external database.
      • If using an external database, provide the database connection details.
    7. SSO Configuration:
      • Configure the Single Sign-On (SSO) domain and site name.
    8. Inventory Size:
      • Select the size of your inventory (tiny, small, medium, large, or x-large).
    9. vCenter Service Account:
      • Provide a username and password for the vCenter Server service account.
    10. Select Installation Location:
      • Choose the installation directory for vCenter.
    11. Configure CEIP:
      • Choose whether to join the Customer Experience Improvement Program.
    12. Ready to Install:
      • Review the configuration settings and click “Install” to begin the installation.
    13. Installation Progress:
      • Monitor the installation progress.
    14. Complete the Installation:
      • Once the installation is complete, click “Finish.”

    Post-Installation Steps:

    1. Access vCenter Server:
      • Open a web browser and navigate to the vCenter Server URL (https://<vCenterServer>/vsphere-client).
    2. Configure vCenter Services:
      • Log in using the SSO administrator credentials.
      • Configure additional vCenter services if necessary.
    3. License vCenter Server:
      • Apply the license key to vCenter Server.
    4. Add ESXi Hosts:
      • In the vSphere Client, add the ESXi hosts to the vCenter inventory.
    5. Create Datacenter and Clusters:
      • Organize your infrastructure by creating datacenters and clusters.
    6. Configure Networking and Storage:
      • Set up networking and storage configurations.
    7. Create Virtual Machines:
      • Start creating virtual machines within the vCenter environment.
    8. Set Up Backup and Monitoring:
      • Implement backup solutions and configure monitoring for your vSphere environment.

    Remember to refer to the official VMware documentation for the version you are installing, as steps may vary slightly based on the specific release.